aboutsummaryrefslogtreecommitdiff
path: root/stylish-haskell/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'stylish-haskell/default.nix')
-rw-r--r--stylish-haskell/default.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/stylish-haskell/default.nix b/stylish-haskell/default.nix
deleted file mode 100644
index bd73cf8..0000000
--- a/stylish-haskell/default.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ HUnit, aeson, base, bytestring, containers, directory, fetchFromGitHub
-, filepath, haskell-src-exts, mkDerivation, mtl, optparse-applicative, stdenv
-, strict, stylish-haskell, syb, test-framework, test-framework-hunit, yaml
-}:
-
-let regularDependencies = [
- aeson
- base
- bytestring
- containers
- directory
- filepath
- haskell-src-exts
- mtl
- syb
- yaml
- ];
-in mkDerivation {
- pname = "stylish-haskell";
- version = "0.8.1.0";
-
- src = fetchFromGitHub {
- owner = "jaspervdj";
- repo = "stylish-haskell";
- rev = "dc3a73e82c19ff97a1544840dac8f7f4568b24bc";
- sha256 = "0kx9m3j9w2357ff5y651s9cdbjiyax9fksyf4rk8pzabc0dv6dpg";
- };
-
- isLibrary = true;
- isExecutable = true;
-
- libraryHaskellDepends =
- regularDependencies;
-
- executableHaskellDepends =
- regularDependencies ++ [ optparse-applicative strict stylish-haskell ];
-
- testHaskellDepends =
- regularDependencies ++ [ HUnit test-framework test-framework-hunit ];
-
- homepage = "https://github.com/jaspervdj/stylish-haskell";
- description = "Simple Haskell code prettifier";
- license = stdenv.lib.licenses.bsd3;
- }