aboutsummaryrefslogtreecommitdiff
path: root/tools.nix
diff options
context:
space:
mode:
authorJoris2017-11-13 23:56:40 +0100
committerJoris2017-11-14 00:03:10 +0100
commit5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1 (patch)
tree4884de1d03bc47ba8f06b2cf68365d9eed9e0d39 /tools.nix
parent213cf7ede058b781fc957de2cd9f6a5988c08004 (diff)
downloadbudget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.tar.gz
budget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.tar.bz2
budget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.zip
Setup stylish-haskell
Diffstat (limited to 'tools.nix')
-rw-r--r--tools.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools.nix b/tools.nix
index a06757e..f09ad13 100644
--- a/tools.nix
+++ b/tools.nix
@@ -1,12 +1,17 @@
with import <nixpkgs> {}; {
env = stdenv.mkDerivation {
name = "tools";
- buildInputs = with pkgs; [
- nodePackages.nodemon
+ buildInputs = with pkgs; with nodePackages; with haskellPackages; [
+ nodemon
sqlite
cabal-install
tmux
tmuxinator
+ (import ./stylish-haskell {
+ inherit mkDerivation aeson base bytestring containers directory filepath
+ fetchFromGitHub haskell-src-exts mtl syb yaml stylish-haskell strict
+ optparse-applicative HUnit test-framework test-framework-hunit stdenv;
+ })
];
};
}