aboutsummaryrefslogtreecommitdiff
path: root/tools.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools.nix')
-rw-r--r--tools.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools.nix b/tools.nix
index a06757e..f09ad13 100644
--- a/tools.nix
+++ b/tools.nix
@@ -1,12 +1,17 @@
with import <nixpkgs> {}; {
env = stdenv.mkDerivation {
name = "tools";
- buildInputs = with pkgs; [
- nodePackages.nodemon
+ buildInputs = with pkgs; with nodePackages; with haskellPackages; [
+ nodemon
sqlite
cabal-install
tmux
tmuxinator
+ (import ./stylish-haskell {
+ inherit mkDerivation aeson base bytestring containers directory filepath
+ fetchFromGitHub haskell-src-exts mtl syb yaml stylish-haskell strict
+ optparse-applicative HUnit test-framework test-framework-hunit stdenv;
+ })
];
};
}