aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2022-01-09 09:43:21 +0100
committerJoris2022-01-09 10:11:29 +0100
commitbd59a5128c05dcd550e91bbdd0cd9d5996a65586 (patch)
tree541f7d49253ad3e7c8dfab480f33a2b10107b0d2 /Cargo.toml
parentce978143f1360e16e85587644055a9f83d11c64c (diff)
downloadcalendar-bd59a5128c05dcd550e91bbdd0cd9d5996a65586.tar.gz
calendar-bd59a5128c05dcd550e91bbdd0cd9d5996a65586.tar.bz2
calendar-bd59a5128c05dcd550e91bbdd0cd9d5996a65586.zip
Persist events to sqlite db
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 277ac45..07c2e20 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,6 +5,9 @@ authors = ["Joris Guyonvarch"]
edition = "2018"
[dependencies]
+anyhow = "1.0"
+async-channel = "1.6"
chrono = "0.4"
gtk4 = { version = "0.3", features = ["v4_2"] }
-async-channel = "1.6"
+rusqlite = { version = "0.26", features = [ "chrono" ] }
+rusqlite_migration = "0.5"