aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9b7de69
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = [
+ elmPackages.elm
+ nodejs
+ tmux
+ tmuxinator
+ ];
+ shellHook = ''
+ tmux kill-session -t catchvoid >/dev/null 2>&1
+ tmuxinator local
+ '';
+ };
+}