aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-09-04 15:52:17 +0200
committerJoris2016-09-04 15:53:32 +0200
commit8714c3befcf3f9923cf72e8d992ba6d963c0e6e7 (patch)
treee5ab35a918a95cbfee2f90dc34f3fe57fac42593 /shell.nix
parentcda08750ac7cdd83e73c1110800bea39928ffed9 (diff)
downloadcatchvoid-8714c3befcf3f9923cf72e8d992ba6d963c0e6e7.tar.gz
catchvoid-8714c3befcf3f9923cf72e8d992ba6d963c0e6e7.tar.bz2
catchvoid-8714c3befcf3f9923cf72e8d992ba6d963c0e6e7.zip
Upgrade to elm 0.17.1
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9b7de69
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = [
+ elmPackages.elm
+ nodejs
+ tmux
+ tmuxinator
+ ];
+ shellHook = ''
+ tmux kill-session -t catchvoid >/dev/null 2>&1
+ tmuxinator local
+ '';
+ };
+}