aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2017-05-08 20:44:45 +0200
committerJoris2017-05-08 20:44:45 +0200
commit14433a928f7fdf9be3193812cbbed1a5ae49ecd7 (patch)
treea9a81b57922ba007f9864db9fbe789e559d10fb3 /shell.nix
parent9e4c00c3df11b7ffc1e9b626ffbf5a74521b5a7a (diff)
downloadcooking-14433a928f7fdf9be3193812cbbed1a5ae49ecd7.tar.gz
cooking-14433a928f7fdf9be3193812cbbed1a5ae49ecd7.tar.bz2
cooking-14433a928f7fdf9be3193812cbbed1a5ae49ecd7.zip
Let the user upgrade an ingredient quantity and adapt other quantities
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 84a4e29..4d32712 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,10 +2,17 @@ with import <nixpkgs> {}; {
env = stdenv.mkDerivation {
name = "env";
buildInputs = with pkgs; [
- nodePackages.nodemon
stack
+ purescript
+ nodePackages.nodemon
+ nodePackages.bower
+ yarn
tmux
tmuxinator
+ nodejs-7_x
];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
};
}