aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 84a4e29..4d32712 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,10 +2,17 @@ with import <nixpkgs> {}; {
env = stdenv.mkDerivation {
name = "env";
buildInputs = with pkgs; [
- nodePackages.nodemon
stack
+ purescript
+ nodePackages.nodemon
+ nodePackages.bower
+ yarn
tmux
tmuxinator
+ nodejs-7_x
];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
};
}