aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-10-29 21:43:37 +0200
committerJoris2016-10-29 21:43:37 +0200
commit14858277fb74c3788af1226f37b22089229edc34 (patch)
treefc3c0a87429362c55673d72518e97a9d6f5bd80d /shell.nix
parent57c4fa462996307293e3da3068ec40ef69000e13 (diff)
downloadcooking-14858277fb74c3788af1226f37b22089229edc34.tar.gz
cooking-14858277fb74c3788af1226f37b22089229edc34.tar.bz2
cooking-14858277fb74c3788af1226f37b22089229edc34.zip
Use Hakyll to generate web pages
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..eb2427e
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ # ghc
+ cabal-install
+ cabal2nix
+ tmux
+ tmuxinator
+ (haskellPackages.ghcWithPackages (p: with p; [
+ (haskell.lib.dontCheck hakyll)
+ clay
+ text
+ ]))
+ ];
+ };
+}