aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..eb2427e
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ # ghc
+ cabal-install
+ cabal2nix
+ tmux
+ tmuxinator
+ (haskellPackages.ghcWithPackages (p: with p; [
+ (haskell.lib.dontCheck hakyll)
+ clay
+ text
+ ]))
+ ];
+ };
+}