aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-02-13 18:54:18 +0100
committerJoris2020-02-15 10:59:25 +0100
commit7a01b001ccc4a7bda3da92486903540e3f9754fd (patch)
treefbe269faa319fd7f21049612f8a62c0c169f369e /shell.nix
parent8328c11ac6706e3adf9b09877c02897132b8927a (diff)
downloadcooking-7a01b001ccc4a7bda3da92486903540e3f9754fd.tar.gz
cooking-7a01b001ccc4a7bda3da92486903540e3f9754fd.tar.bz2
cooking-7a01b001ccc4a7bda3da92486903540e3f9754fd.zip
Set up bucklescript
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix23
1 files changed, 9 insertions, 14 deletions
diff --git a/shell.nix b/shell.nix
index 02dacb8..e07f28f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,23 +1,18 @@
with import (builtins.fetchTarball {
- url = https://github.com/NixOS/nixpkgs/archive/19.09.tar.gz;
- sha256 = "0mhqhq21y5vrr1f30qd2bvydv4bbbslvyzclhw0kdxmkgg3z4c92";
-}) {
- overlays = [
- (self: super: {
- nodePackages = import ./nix/nodePackages {};
- })
- ];
-};
-
+ # https://github.com/NixOS/nixpkgs/commit/77752c6c086512a7c1eb066edcef731696fa2a8e
+ name = "nixpkgs-20-12-2019";
+ url = https://github.com/nixos/nixpkgs/archive/77752c6c086512a7c1eb066edcef731696fa2a8e.tar.gz;
+ sha256 = "1sb6c9pzq4rjc8sj41qw01b38119xk91pmlxwl80fqhg8mj1ai8r";
+}) {};
mkShell {
buildInputs = [
- entr
- nodePackages.rollup
- nodePackages.terser
- nodePackages.typescript
+ bs-platform
+ nodejs
tmux
tmuxinator
zola
+ python
+ ocamlformat
];
}