aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix23
1 files changed, 9 insertions, 14 deletions
diff --git a/shell.nix b/shell.nix
index 02dacb8..e07f28f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,23 +1,18 @@
with import (builtins.fetchTarball {
- url = https://github.com/NixOS/nixpkgs/archive/19.09.tar.gz;
- sha256 = "0mhqhq21y5vrr1f30qd2bvydv4bbbslvyzclhw0kdxmkgg3z4c92";
-}) {
- overlays = [
- (self: super: {
- nodePackages = import ./nix/nodePackages {};
- })
- ];
-};
-
+ # https://github.com/NixOS/nixpkgs/commit/77752c6c086512a7c1eb066edcef731696fa2a8e
+ name = "nixpkgs-20-12-2019";
+ url = https://github.com/nixos/nixpkgs/archive/77752c6c086512a7c1eb066edcef731696fa2a8e.tar.gz;
+ sha256 = "1sb6c9pzq4rjc8sj41qw01b38119xk91pmlxwl80fqhg8mj1ai8r";
+}) {};
mkShell {
buildInputs = [
- entr
- nodePackages.rollup
- nodePackages.terser
- nodePackages.typescript
+ bs-platform
+ nodejs
tmux
tmuxinator
zola
+ python
+ ocamlformat
];
}