aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2024-05-20 20:09:01 +0200
committerJoris2024-06-02 14:20:50 +0200
commite8da9790dc6d55cd2e8883322cdf9a7bf5b4f5b7 (patch)
treec960e1036e3d93c1f91b58dfe9e3c8e6038ed363 /flake.nix
parentd2f33d8e854b7fda6bae389d983025e6c8609842 (diff)
Migrate to sanic
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 92951f0..170fe8d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,9 +13,12 @@
(pkgs.python3.withPackages (pythonPackages: with pythonPackages; [
sqlite
watchexec
+ sanic
+ setuptools
]))
];
shellHook = ''
+ export DEBUG="TRUE"
export HOST="127.0.0.1"
export PORT="8080"
export KEY="1234"