diff options
author | Joris | 2021-05-29 19:24:41 +0200 |
---|---|---|
committer | Joris | 2021-05-29 19:24:41 +0200 |
commit | d48cafebb277e4ad4b31e883cbe4f55eef9ea4a4 (patch) | |
tree | 7f04fb49defa5fbc7984b0eee60bb7ce16a37ae2 /shell.nix | |
parent | 4e3cd92a8063a70dab9ae0ccafd0552c78c6e005 (diff) |
Rewrite in TypeScript
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 31 |
1 files changed, 16 insertions, 15 deletions
@@ -1,16 +1,17 @@ -with import <nixpkgs> {}; { - env = stdenv.mkDerivation { - name = "env"; - buildInputs = with pkgs; [ - yarn - nodePackages.bower - purescript - tmux - tmuxinator - webfs - ]; - shellHook = '' - export PATH=node_modules/.bin:$PATH; - ''; - }; +with (import (builtins.fetchGit { + name = "nixpkgs-20.09"; + url = "git@github.com:nixos/nixpkgs.git"; + rev = "cd63096d6d887d689543a0b97743d28995bc9bc3"; + ref = "refs/tags/20.09"; +}){}); + +mkShell { + + buildInputs = [ + nodePackages.typescript + python3 + python3Packages.beautifulsoup4 + psmisc # fuser + ]; + } |