aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix31
1 files changed, 16 insertions, 15 deletions
diff --git a/shell.nix b/shell.nix
index e7e0323..3bffe92 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,16 +1,17 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = with pkgs; [
- yarn
- nodePackages.bower
- purescript
- tmux
- tmuxinator
- webfs
- ];
- shellHook = ''
- export PATH=node_modules/.bin:$PATH;
- '';
- };
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.09";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
+ ref = "refs/tags/20.09";
+}){});
+
+mkShell {
+
+ buildInputs = [
+ nodePackages.typescript
+ python3
+ python3Packages.beautifulsoup4
+ psmisc # fuser
+ ];
+
}