aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-05-08 14:12:47 +0200
committerJoris2020-05-08 14:14:16 +0200
commitdf828c4b141f84f731afffbe17c80618cacf9480 (patch)
treeaeae4a185c3f23da0331b32139c072ebe50b50dd /shell.nix
parent2abfaddc6a3a5233018ad285421eaf531a01a283 (diff)
downloadtodo-df828c4b141f84f731afffbe17c80618cacf9480.tar.gz
todo-df828c4b141f84f731afffbe17c80618cacf9480.tar.bz2
todo-df828c4b141f84f731afffbe17c80618cacf9480.zip
Bootstrap todo-next
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..608e7c1
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.03";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "5272327b81ed355bbed5659b8d303cf2979b6953";
+ ref = "refs/tags/20.03";
+}) {});
+
+mkShell {
+
+ buildInputs = [
+ qt5.full
+ sqlite
+ ];
+
+ propagatedBuildInputs = [
+ python38Packages.pyqt5
+ ];
+
+}