aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..608e7c1
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.03";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "5272327b81ed355bbed5659b8d303cf2979b6953";
+ ref = "refs/tags/20.03";
+}) {});
+
+mkShell {
+
+ buildInputs = [
+ qt5.full
+ sqlite
+ ];
+
+ propagatedBuildInputs = [
+ python38Packages.pyqt5
+ ];
+
+}